Undefined

123 Flash Menu Placeholder.


Авторы

Автор учебника: Гореленков А.И.

Верстка и дизайн: Василенкова Т.В., Манушкина Е.В.,Иванов К.А.

Научный руководитель: Малахов Ю.А.


Электронный учебник по дисциплине "Линейная алгебра"

Автор учебника: Гореленков А.И.

Верстка и дизайн: Василенкова Т.В., Манушкина Е.В., Иванов К.А.

Научный руководитель: Малахов Ю.А.

СОДЕРЖАНИЕ

Тема 1. Матрицы и определители

1.1. Матрицы и операции над ними

1.2. Определитель матрицы

1.3. Обратная матрица

1.4. Ранг матрицы

Тема 2. Системы линейных уравнений

2.1. Основные понятия и определения

2.2. Невырожденные системы линейных уравнений

2.3. Метод Гаусса

2.4. Однородные системы линейных уравнений

Тема 3. Векторная алгебра

3.1. Основные понятия и определения

3.2. Линейные операции над векторами

3.3. Разложение векторов. Базис системы векторов

3.4. Проекция вектора на ось

3.5. Скалярное произведение двух векторов

3.6. Векторное произведение двух векторов

3.7. Смешанное произведение трех векторов

Тема 4. Алгебраические структуры

4.1. Множества и операции над ними

4.2. Отображения множеств

4.3. Бинарные алгебраические операции

4.4. Алгебраические структуры с одной операцией

4.5. Алгебраические структуры с двумя операциями

Тема 5. Поле комплексных чисел

5.1. Основные понятия и определения

5.2. Геометрическое представление комплексных чисел

5.3. Тригонометрическая форма комплексного числа

Вопросы по темам

Глоссарий, определения

Литература


1.1. Матрицы и операции над ними

Определение. Матрицей размера m×n называется прямоугольная таблица из m строк и n столбцов, состоящая из чисел или иных математических выражений.

Числа (или математические выражения), составляющие матрицу, называются элементами матрицы.

Матрицы обозначаются прописными буквами латинского алфавита, а для обозначения элементов матрицы используются соответствующие строчные буквы с двойной индексацией. Первый индекс означает номер строки, а второй – номер столбца, в которых находится элемент. Например, [image] – матрица размера 2×3, ее элементы а11 = 1, а12 = х, а13 = 3, а21 = –2y, а22 = –5, а23 = 0.

Матрица А с элементами аij , обозначается также [image].

Матрица, в которой число строк равно числу столбцов n, называется квадратной матрицей n-го порядка. Элементы матрицы, у которых номер строки равен номеру столбца (i = j), называются диагональными и образуют главную диагональ матрицы. Квадратная матрица, в которой все элементы, кроме диагональных, равны нулю, называется диагональной. Квадратная матрица, в которой все элементы, расположенные по одну сторону от диагональных, равны нулю, называется треугольной матрицей.

Элемент строки матрицы называется крайним, если он отличен от нуля, а все элементы этой строки, находящиеся левее него, равны нулю. Матрица называется ступенчатой, если крайний элемент каждой строки находится правее крайнего элемента предыдущей строки.

Примеры матриц: а) квадратная; б) диагональная; в) треугольная; г) ступенчатая:

а) [image]; б) [image]; в) [image]; г) [image].

Введем следующие операции над матрицами.

Определение. Суммой матриц [image] и [image] одинаковых размеров называется матрица, элементы которой равны суммам соответствующих элементов матриц А и В, т.е. .

Например, [image].

Сложение матриц обладает следующими свойствами:

1. А + В = В + А (коммутативность сложения)

2. (А + В) + С = А + (В + С) (ассоциативность сложения).

Для любой матрицы А существует матрица 0, называемая нулевой, такая что А + 0 = 0 + А = А. Все элементы нулевой матрицы равны нулю. Для каждой матрицы А существует матрица А', называемая противоположной к матрице А, такая, что А + А' = А' + А = 0. Матрица, противоположная к А, обозначается –А. Очевидно, что если [image], то [image]. Отсюда следует, что можно ввести операцию вычитания матриц А и В, определенную как сумма А и –В: А – В = А + (–В). Элементы матрицы А – В будут равны разностям соответствующих элементов матриц А и В.

Определение. Произведением матрицы [image] на число k называется матрица, элементы которой равны элементам матрицы А, умноженным на это число т.е. .

Так, если [image], то [image].

Произведение матрицы на число обладает следующими свойствами:

1. k(A + B) = kA + kB (дистрибутивность умножения относительно сложения матриц).

2. (k1 + k2)A = k1A + k2A (дистрибутивность умножения относительно сложения чисел).

3. k1(k2A) = (k1k2)A (ассоциативность).

4. 1·А = А.

Определение. Произведением матрицы [image] размера m×n на матрицу [image] размера n×p называется матрица [image] размера m×p, в которой сij = ai1b1j + ai2b2j + … + ainbnj.

То есть, для нахождения элемента сij нужно элементы i-й строки матрицы А умножить на соответствующие элементы j-го столбца матрицы В и результаты сложить. К использованию именно такого правила умножения приводят многочисленные применения матриц на практике.

Из определения видно, что умножить матрицу А на матрицу В можно лишь в том случае, когда число столбцов матрицы А равно числу строк матрицы В. Так, если [image], то [image].

Операция умножения матриц обладает следующими свойствами

1. (АВ)С = А(ВС) (ассоциативность умножения).

2. А(В + С) = АВ + АС (левая дистрибутивность умножения относительно сложения).

3. (А + В)С = АС + ВС (правая дистрибутивность умножения относительно сложения).

Умножение матриц не является коммутативной операцией, т.е. АВ ≠ ВА. Это следует из ограничений на размеры перемножаемых матриц. Но даже и в том случае, когда перемножаются квадратные матрицы одного порядка n, равенство АВ = ВА выполняется не для всех матриц. Вместе с тем, для любой квадратной матрицы А существует матрица Е, называемая единичной, такая что АЕ = ЕА. Она при умножении матриц играет роль единицы, поскольку АЕ = ЕА = А. Матрица Е является диагональной матрицей, в которой каждый диагональный элемент равен единице. Например, [image] – единичная матрица второго порядка.

Определение. Транспонированием матрицы [image] размера m×n называется преобразование матрицы А в матрицу размера n×m заменой строк столбцами с сохранением их номеров.

Матрица, транспонированная к А, обозначается АТ.

Так, если [image], то [image].

Операция транспонирования матриц обладает следующими свойствами.

1. (А + В)Т = АТ + ВТ.

2. (kA)Т = kAТ.

3. (АВ)Т = ВТАТ.

Определение. Элементарными преобразованиями матрицы называются следующие операции:
1. Перестановка местами двух строк.
2. Умножение всех элементов строки на число, не равное нулю.
3. Прибавление к каждому элементу строки соответствующих элементов другой строки, умноженных на произвольное число.

При осуществлении элементарных преобразований матрицы строки будем обозначать, в соответствии с их номерами, римскими цифрами: I (первая), II (вторая) и т.д. Так, запись II + 2·I означает, что на место второй строки записывается результат сложения удвоенной первой строки со второй.

Матрица В, полученная из матрицы А с помощью элементарных преобразований, называется эквивалентной матрице А (обозначается В~А).

При помощи элементарных преобразований любую матрицу можно привести к ступенчатому виду.

Пример. Привести к ступенчатому виду матрицу [image].

Решение. ~ [image] ~ [image] ~ [image].


1.2. Определитель матрицы

Квадратной матрице [image] можно поставить в соответствие число, которое называется определителем (детерминантом) матрицы А, и обозначается [image] или |A| или det A.

Определение. Определителем матрицы первого порядка [image] называется элемент а11, т.е. .

Так, если [image], то [image].

Определение. Определителем матрицы второго порядка [image] называется число [image].

Так, если [image], то [image].

Определение. Определителем матрицы третьего порядка [image] называется число |A| = a11a22a23 + a12a23a31 + a13a21a32 – a13a22a31 – a11a23a32 – a12a21a33.

Так, если [image], то |A| = 5·1·(–3) + (–2)·(–4)·6 + 1·3·0 – 1·1·6 – 5·(–4)·0 – (–2)·3·(–3) = –15 + 48 + 0 – 6 – 0 – 18 = 9 .

Для облегчения запоминания формулы определителя третьего порядка используется «правило треугольников»: со знаком «+» берутся произведения элементов, стоящих на главной диагонали и в вершинах двух треугольников у которых одна из сторон параллельна главной диагонали; со знаком «–» берутся произведения элементов, стоящих на побочной диагонали и в вершинах двух треугольников у которых одна из сторон параллельна побочной диагонали. Схематически «правило треугольников» изображается следующим образом:

Таким образом, определитель второго порядка есть алгебраическая сумма 2 = 2! слагаемых, каждое из которых представляет собой произведение двух сомножителей – элементов матрицы, по одному из каждой строки и каждого столбца. Одно из слагаемых берется со знаком «+», другое – со знаком «–». Определитель третьего порядка есть алгебраическая сумма 6 = 3! слагаемых, каждое из которых представляет собой произведение трех сомножителей – элементов матрицы, по одному из каждой строки и каждого столбца. Одна половина слагаемых берется со знаком «+», другая – со знаком «–». Учитывая подмеченные закономерности, перейдем к определению определителя матрицы n-го порядка.

Определителем матрицы n-го порядка называется число, равное алгебраической сумме n! слагаемых, каждое из которых представляет собой произведение n сомножителей – элементов матрицы, по одному из каждой строки и каждого столбца. Одна половина слагаемых берётся со знаком «+», другая – со знаком «–».

Число слагаемых в формуле вычисления определителя матрицы n-го порядка резко увеличивается с ростом n. Так, даже для определителя четвертого порядка придётся просуммировать 4! = 24 слагаемых. Поэтому на практике при вычислении определителей высоких порядков используются другие формулы. Для их рассмотрения введем новые понятия.

Определение. Минором Mij элемента aij матрицы n-го порядка [image] называется определитель матрицы (n–1)-го порядка, полученной из матрицы A вычёркиванием i-й строки и j-го столбца.

Например, в матрице [image] минором M12 является определитель, составленный из элементов матрицы А, оставшихся после вычеркивания первой строки и второго столбца: .

Определение. Алгебраическим дополнением Aij элемента aij матрицы n-го порядка [image] называется его минор Mij, взятый со знаком [image].

Например, в матрице [image] алгебраическим дополнением A12 будет число [image].

Теорема Лапласа. Определитель квадратной матрицы n-го порядка равен сумме произведений элементов любой строки (столбца) матрицы на их алгебраические дополнения: (разложение по i-й строке); [image] (разложение по j-му столбцу).

Теорема Лапласа позволяет свести вычисление определителей n-го порядка к вычислению более простых определителей (n-1)-го порядка.

Пример. Вычислить определитель [image] разложением по какой-нибудь строке или столбцу.

Решение. Удобнее пользоваться разложением по строке или столбцу, содержащим наибольшее количество нулей. Разложим определитель по первой строке.

.

Заметим, что при вычислении определителей разложением по строке или столбцу, знаки (–1)i+j («+» или «–») перед слагаемыми aijMij расположены в «шахматном» порядке (слева вверху знак «+»).

Укажем основные свойства определителя матрицы:

1. При транспонировании матрицы ее определитель не изменяется.

2. При перестановке местами двух строк (двух столбцов) определитель меняет знак.

3. Общий множитель всех элементов строки (столбца) определителя можно выносить за знак определителя.

4. Определитель, содержащий две одинаковые строки (два одинаковых столбца), равен нулю.

5. Определитель не изменится, если к элементам строки (столбца) прибавить соответствующие элементы другой строки (столбца), умноженные на произвольное число.

Свойства определителя позволяют существенно упростить вычисления определителей матриц высоких порядков. Целесообразно преобразовать матрицу так, чтобы преобразованная матрица имела строку (или столбец), содержащую как можно больше нулей, а потом вычислить определитель разложением по этой строке (столбцу).

Пример. Вычислить определитель [image].

Решение. Прибавим к элементам второй, третьей и четвертой строк, соответствующие элементы первой строки, умноженные соответственно на –2, –3 и –4. Получим [image] – определитель треугольной матрицы, который равняется произведению элементов главной диагонали. Перемножая диагональные элементы, получаем –20.


1.3. Обратная матрица

Для каждого числа а ≠ 0 существует обратное число а–1 такое, что а–1·а = а·а–1 = 1. Для квадратных матриц тоже вводится аналогичное понятие.

Определение. Матрица А–1 называется обратной по отношению к квадратной матрице А, если при умножении этой матрицы на данную как справа, так и слева получается единичная матрица Е, т.е. А–1·А = А·А–1 = Е.

Из определения следует, что только квадратная матрица имеет обратную. Однако не каждая квадратная матрица имеет обратную. Если необходимым и достаточным условием существования обратного числа а–1 является условие а ≠ 0, то для существования обратной матрицы А–1 таким условием является det A ≠ 0.

Определение. Квадратная матрица называется невырожденной, если ее определитель отличен от нуля; в противном случае матрица называется вырожденной.

Теорема. Любая невырожденная матрица n-го порядка [image] имеет единственную обратную матрицу А–1, которую можно найти по формуле

,

где det A – определитель матрицы А, Аij – алгебраическое дополнение элемента aij матрицы А.

Из теоремы следует алгоритм вычисления матрицы А–1 обратной по отношению к матрице А:

1. Вычисляем определитель матрицы А. Если det A ≠ 0, то матрица А – невырожденная и обратная к ней матрица А–1 существует. Если det A = 0, то матрица А – вырожденная и обратной матрицы А–1 не существует.

2. Находим алгебраические дополнения элементов матрицы А.

3. Каждый элемент матрицы А заменяем его алгебраическим дополнением. Транспонируем полученную матрицу и умножаем на число [image].

Пример. Найти матрицу, обратную к матрице [image].

Решение. det A = 5. Определитель матрицы А не равен нулю, т.е. матрица А – невырожденная и обратная матрица А–1 существует. Находим алгебраические дополнения элементов матрицы А: , [image], [image], [image], [image], [image], [image], [image], [image]. Вычисляем обратную матрицу А–1: .

Метод нахождения обратной матрицы через алгебраические дополнения не является единственным. Обратную матрицу можно получить, используя элементарные преобразования матрицы.

К матрице А, по отношению к которой находится обратная матрица А–1, приписывается справа единичная матрица Е. Элементарными преобразованиями над строками расширенной матрицы (A ¦ E) матрица А приводится к виду единичной матрицы Е. После преобразований на месте приписанной справа единичной матрицы Е будет находиться обратная матрица А–1, т.е.

(A ¦ E) ~ (E ¦ A–1).

Пример. Элементарными преобразованиями найти матрицу, обратную к матрице [image].

Решение. det A = 1. Определитель матрицы не равен нулю, т.е. обратная матрица А–1 существует. Приписываем к матрице А справа единичную матрицу Е и преобразовываем матрицу (A ¦ E).
~ [image] ~ [image] ~ [image] ~ [image]. Итак, [image].

При решении практических задач многие из них сводятся к уравнениям, в которых неизвестным является некоторая матрица. Такие уравнения называются матричными.

Рассмотрим решение уравнений АХ = В и ХА = В, где А, В – заданные матрицы, Х – неизвестная матрица. Эти уравнения имеют единственные решения только в том случае, если А – невырожденная матрица и определена операция умножения. Для решения первого уравнения АХ = В обе его части умножают слева на матрицу А–1. Получается А–1(АХ) = А–1В. Ввиду ассоциативности произведения матриц: А–1(АХ) = (А–1А)Х. Так как А–1А = Е, а EX = X, то Х = А–1В.

Для решения второго уравнения ХА = В обе его части умножают на А–1 справа. Так как (ХА)А–1 = Х(АА–1) = ХЕ = Х, то Х = ВА–1.

Для решения более сложного уравнения AXB = С , где А и В – невырожденные матрицы, обе его части умножают на А–1 слева и на В–1 справа. После чего получается Х = А–1СВ–1.

Пример. Решить матричное уравнение [image].

Решение. Обозначим [image], [image]. Уравнение имеет вид: АХ = В. Его решением является матрица Х = А–1В. Находим обратную матрицу А–1. Определитель матрицы равен 1, т.е. обратная матрица А–1 существует.
A11 = 1; A12 = –1; A21 = –2; A22 = 3; [image].
Вычисляем матрицу Х: .


1.4. Ранг матрицы

Рассмотрим матрицу А размера m×n. Вычеркивая некоторые строки и (или) столбцы, из матрицы А можно получить квадратные матрицы k-го порядка, где k не превосходит меньшего из размеров матрицы А. Так, из матрицы [image] можно получить три матрицы второго порядка и шесть матриц первого порядка.

Определение. Минором k-го порядка матрицы А называется определитель матрицы k-го порядка, полученной из матрицы А вычёркиванием некоторого числа её строк и (или) столбцов.

Из всех возможных миноров матрицы рассмотрим те, которые отличны от нуля.

Определение. Рангом матрицы называется наивысший порядок отличных от нуля миноров этой матрицы.

Так, матрица [image] имеет ранг, равный двум, так как существует минор второго порядка [image], отличный от нуля, а миноров третьего порядка у матрицы А нет.

Ранг матрицы А обозначается rang A или r(A).

Из определения следует, что 1) ранг прямоугольной матрицы A не превосходит меньшего из её размеров, т.е. r(A) ≤ min(n, m); 2) ранг квадратной матрицы n-го порядка А равен n, если ее определитель |A| не равен нулю; 3) ранг матрицы равен нулю, если все её элементы равны нулю.

Для вычисления ранга ненулевой матрицы находят любой её минор 2-го порядка, отличный от нуля. Если такого минора нет, то ранг матрицы равен 1. Если такой минор найден, то вычисляют миноры 3-го порядка, окаймляющие ненулевой минор 2-го порядка. Если таких миноров нет, или они все равны нулю, то ранг матрицы равен 2. Если есть ненулевой минор 3-го порядка, то процесс продолжают. Так поступают до тех пор, пока не обнаруживается, что все окаймляющие миноры некоторого, например, i-го порядка равны нулю. Тогда ранг матрицы равен i-1.

Данный метод вычисления ранга матрицы называется методом окаймляющих миноров.

Пример. Методом окаймляющих миноров вычислить ранг матрицы [image].

Решение. Так как у матрицы А есть ненулевые элементы, то ранг матрицы больше нуля. Находим минор 2-го порядка, отличный от нуля. Например, минор [image]. Вычисляем окаймляющие его миноры 3-го порядка: , [image]. Все окаймляющие миноры 3-го порядка равны нулю. Следовательно, ранг матрицы А равен 2.

Вычисление ранга матрицы методом окаймляющих миноров трудоемко. Существует второй способ, базирующийся на следующих теоремах.

Теорема. При элементарных преобразованиях ранг матрицы не изменяется.

Теорема. Ранг ступенчатой матрицы равен количеству ее ненулевых строк.

Из теорем следует, что для нахождения ранга матрицы можно матрицу элементарными преобразованиями привести к ступенчатому виду и подсчитать количество ее ненулевых строк.

Пример. Методом элементарных преобразований вычислить ранг матрицы [image].

Решение. ~ [image] ~ [image] ~ [image].
Полученная ступенчатая матрица содержит три ненулевые строки. Следовательно, ранг матрицы А равен 3.

Определение. Ненулевой минор, порядок которого равняется рангу матрицы, называется базисным.

У матрицы может быть несколько базисных миноров. Так, базисными минорами матрицы [image] являются миноры [image] и [image].


2.1. Основные понятия и определения

Определение. Системой линейных алгебраических уравнений, содержащей m уравнений и n неизвестных, называется система вида [image] ,где aij , bi (i = 1, 2, …, m; j = 1, 2, …, n) – заданные числа, называемые соответственно коэффициентами при неизвестных xj и свободными членами уравнений.

Обозначим: – матрица коэффициентов при неизвестных, или основная матрица системы, [image] – матрица-столбец неизвестных, [image] – матрица-столбец свободных членов.

Так как число столбцов матрицы А равно числу строк матрицы Х, то произведение матриц определено. Элементами матрицы АХ являются левые части системы уравнений. Тогда, на основании определения равенства матриц, систему линейных алгебраических уравнений можно записать в виде: АХ = В. Данная запись называется матричной формой системы уравнений.

Матрица A дополненная справа столбцом свободных членов B называется расширенной матрицей Ã системы: .

Решением системы линейных уравнений называется совокупность n чисел x1 = c1, x2 = c2, …, xn = cn , при подстановке которых каждое уравнение системы обращается в верное равенство.

Система уравнений называется совместной, если она имеет хотя бы одно решение, и несовместной, если она не имеет решений.

Теорема Кронекера-Капелли. Система линейных уравнений совместна только тогда, когда ранг основной матрицы системы равен рангу расширенной матрицы системы.

Пример. Выяснить, совместна или несовместна система линейных уравнений

Решение. Записываем расширенную матрицу системы и приводим ее к ступенчатому виду с помощью элементарных преобразований:

~ [image] ~ [image].

Ранг основной матрицы системы равен рангу расширенной матрицы системы. Следовательно, система совместна.

Совместная система называется определенной, если она имеет единственное решение, и неопределенной, если она имеет более одного решения. Каждое решение неопределенной системы уравнений называется частным решением системы. Совокупность всех частных решений называется общим решением системы.

Теорема. Если ранг основной матрицы совместной системы линейных уравнений равен числу неизвестных, то система имеет единственное решение. Если ранг основной матрицы совместной системы уравнений меньше числа неизвестных, то система имеет бесконечное множество решений.

Так, ранг матрицы системы уравнений [image] равный 2, меньше числа неизвестных. Следовательно, система имеет бесконечное множество решений.

Две системы уравнений называются эквивалентными, или равносильными, если они имеют одно и то же множество решений.

Эквивалентные системы получаются, в частности, при элементарных преобразованиях системы уравнений, т.е. умножении уравнений на числа, не равные нулю; сложении уравнений.


2.2. Невырожденные системы линейных уравнений

Рассмотрим систему n линейных уравнений с n неизвестными

Основная матрица А такой системы является квадратной. Определитель этой матрицы [image] называется определителем системы . Если определитель системы отличен от нуля, то система называется невырожденной. В этом случае система совместна и определена, т.е. имеет единственное решение.

Так как определитель матрицы А не равен нулю, то существует обратная матрица А–1 . Умножая слева обе части матричного равенства АХ = В на А–1, получим решение системы – матрицу-столбец Х = А–1В. Отыскание решения системы уравнений по формуле Х = А–1В называется матричным методом решения системы.

Пример. Решить систему уравнений [image] матричным методом.

Решение. Обозначаем [image], [image], [image].

Вычисляем определитель основной матрицы системы: . Так как определитель не равен нулю, то обратная матрица А–1 существует.

Находим алгебраические дополнения элементов матрицы А : , [image], [image] , [image], [image], [image] , [image], [image], [image].

Вычисляем обратную матрицу А–1: .

Находим решение системы уравнений: , т.е. решение системы (–1; 2; 1).

Запишем матричное равенство Х = А–1В в виде [image] .

После умножения матриц получаем [image] .

Отсюда следует, что

,

,

…………………………………

.

По теореме Лапласа [image] есть разложение определителя [image] по элементам первого столбца.

Определитель Δ1 получается из определителя системы [image] путем замены первого столбца столбцом свободных членов. Следовательно, [image], где символом Δ обозначен определитель системы [image] .

Аналогично: , где определитель Δ2 получается из определителя системы [image] путем замены второго столбца столбцом свободных членов, [image], …, [image].

Итак, невырожденная система линейных уравнений имеет единственное решение, определяемое по формулам: (i = 1, 2, …, n) , где Δi – определитель, полученный из определителя системы Δ заменой i -го столбца столбцом свободных членов. Формулы [image] (i = 1, 2, …, n) называются формулами Крамера .

Пример . Решить систему уравнений [image] по формулам Крамера.

Решение . Находим определитель системы: .

Так как Δ не равно 0 , то решение системы существует и оно единственно. Вычисляем определители Δ1, Δ2 и Δ3, полученные из определителя Δ заменой соответственно первого, второго и третьего столбцов столбцом свободных членов: , [image] , [image] .

Теперь по формулам Крамера: , [image] , [image] , т.е. решение системы [image].

Матричный метод и метод Крамера решения систем уравнений являются трудоемкими по количеству вычислительных операций. Существуют более экономичные методы решения. Одним из них является метод Гаусса.


2.3. Метод Гаусса

Метод Гаусса – метод последовательного исключения неизвестных – заключается в том, что с помощью элементарных преобразований система уравнений приводится к равносильной системе ступенчатого (в частности, треугольного) вида, из которой последовательно находятся все неизвестные.

Так, система уравнений [image] сложением второго уравнения с первым, а третьего со вторым, приводится к равносильной ей системе треугольного вида: Из третьего уравнения находим [image] ; подставляя это значение во второе уравнение, получаем [image]; из первого уравнения [image], т.е. решение системы [image].

Переход исходной системы к равносильной ей системе ступенчатого вида называется прямым ходом метода Гаусса, а нахождение неизвестных из ступенчатой системы –обратным ходом.

При элементарных преобразованиях системы уравнений преобразуются только коэффициенты и свободные члены системы. Поэтому преобразования удобно проводить не над самими уравнениями, а над строками расширенной матрицы системы. Тогда общая схема решения системы линейных уравнений методом Гаусса следующая: 1) расширенная матрица системы уравнений элементарными преобразованиями приводится к ступенчатому виду (прямой ход), 2) по ступенчатой матрице восстанавливается система уравнений, эквивалентная исходной, которая решается «снизу вверх» (обратный ход).

В случае решения определенной системы уравнений, после элементарных преобразований расширенной матрицы системы, получается треугольная система n уравнений с n неизвестными.

Пример. Решить систему уравнений [image] методом Гаусса.

Решение. Приводим расширенную матрицу системы уравнений к ступенчатому виду:

~ [image] ~ [image].

Записываем систему уравнений, соответствующую полученной расширенной матрице: Из третьего уравнения [image]; подставляя это значение во второе уравнение, получаем [image]; из первого уравнения [image], т.е. решение системы [image] .

Существует модификация метода Гаусса, метод Жордана-Гаусса, заключающийся в преобразовании расширенной матрицы системы к виду, при котором неизвестные системы образуют диагональную матрицу. Это позволяет сразу, без дополнительных вычислений, получить решение системы уравнений.

Пример. Решить систему уравнений [image] методом Жордана-Гаусса.

Решение. Приводим левую часть расширенной матрицы системы уравнений к диагональному виду:

~ [image] ~ [image] ~ [image] ~ [image].

Записываем систему уравнений, соответствующую полученной расширенной матрице: из которой выписываем решение системы [image] .

Помимо меньшей трудоемкости, метод Гаусса позволяет решать неопределенные системы линейных уравнений, т.е. системы, имеющие бесконечное множество решений.

Система имеет бесконечное множество решений, если ранг r матрицы совместной системы уравнений меньше числа n неизвестных. В этом случае, после элементарных преобразований расширенной матрицы системы, получается ступенчатая система r уравнений с n неизвестными.

Определение. r неизвестных системы уравнений называются основными (или базисными), если определитель матрицы из коэффициентов при них (базисный минор) отличен от нуля. Остальные n – r неизвестных называются неосновными (или свободными).

Определяем, какие неизвестные в ступенчатой системе будут основными, какие свободными. Основные неизвестные оставляем слева, свободные переносим в правые части уравнений. Находим выражения базисных неизвестных через свободные. Обозначая свободные неизвестные через ti (i = 1, 2, …, n – r), получаем общее решение системы уравнений. Придавая свободным неизвестным произвольные числовые значения, находим частные решения системы уравнений.

Пример. Найти общее и одно частное решения системы уравнений

Решение. Приводим к ступенчатому виду расширенную матрицу системы:

~ [image] ~ [image] .

Так как ранг основной матрицы системы равен рангу расширенной матрицы, то система совместна.

Количество основных неизвестных системы равно рангу r матрицы системы и равно 2, количество свободных неизвестных равно [image] .

Записываем систему уравнений, соответствующую полученной расширенной матрице:

Определитель при неизвестных х1 , х2 отличен от нуля: . Неизвестные х1 , х2 будут основными, а х3 – свободной. Переносим свободную неизвестную х3 в правые части уравнений:

Подставляя выражение для х2 в первое уравнение, находим [image] . Обозначая свободную неизвестную х3 через t, получаем общее решение системы: . Частное решение системы получим, например, при t = 0: .

Пример. Найти общее и одно частное решения системы уравнений

Решение. Приводим к ступенчатому виду расширенную матрицу системы:

~ [image] ~ [image] .

Так как ранг основной матрицы системы равен рангу расширенной матрицы, то система совместна.

Количество основных неизвестных системы равно рангу r матрицы системы и равно 2, количество свободных неизвестных равно [image].

Записываем систему уравнений, соответствующую полученной расширенной матрице:

Определитель при неизвестных х3 , х4 отличен от нуля: . Неизвестные х3 , х4 будут основными, а х1 , х2 – свободными. Заметим, что в качестве главных неизвестных в данном примере нельзя выбрать пару x1 и х2 , так как соответствующий им минор равен нулю: . Переносим свободные неизвестные х1 , х2 в правые части уравнений:

Подставляя значение х4 = 1 в первое уравнение, находим [image] . Обозначая свободную неизвестную х1 через t1 , а х2 через t2 , получаем общее решение системы: . Частное решение системы получим, например, при t = 1: .

Таким образом, метод Гаусса позволяет однозначно установить, совместна система или нет, и в случае совместности найти ее решения (единственное или бесконечное множество).


2.4. Однородные системы линейных уравнений

Определение .Система линейных алгебраических уравнений называется однородной, если свободные члены всех ее уравнений равны нулю, т.е. система

Однородная система уравнений всегда совместна, так как имеет, по крайней мере, нулевое (или тривиальное) решение [image] . Особый интерес представляет случай, когда однородная система имеет ненулевое решение.

Теорема. Однородная система линейных уравнений имеет ненулевое решение только тогда, когда ранг матрицы этой системы меньше числа неизвестных.

Из этой теоремы следует, что однородная система линейных уравнений, в которой число уравнений меньше числа неизвестных, всегда имеет ненулевое решение. Если в системе число уравнений равно числу неизвестных, то система имеет ненулевое решение, только тогда, когда определитель системы равен нулю.

Заметим, что однородная система, имеющая одно ненулевое решение, имеет бесконечное множество решений.

Для нахождения общего решения однородной системы линейных уравнений используется метод Гаусса. При этом можно ограничиться преобразованием основной матрицы системы, так как столбец свободных членов однородной системы не изменяется и его можно не писать.

Пример. Найти общее решение однородной системы линейных уравнений

Решение. Приводим к ступенчатому виду основную матрицу системы:

~ [image] ~ [image] .

Количество основных неизвестных системы равно рангу r матрицы системы и равно 2, количество свободных неизвестных равно [image] .

Записываем систему уравнений, соответствующую полученной матрице:

Определитель при неизвестных х1 , х2 отличен от нуля: . Неизвестные х1 , х2 будут основными, а х3 – свободной. Переносим свободную неизвестную х3 в правые части уравнений:

Подставляя выражение для х2 в первое уравнение, находим [image] . Обозначая свободную неизвестную х3 через t, получаем общее решение системы: .

Решения однородной системы линейных уравнений обладают следующими свойствами:

1. Если [image] является решением однородной системы, то для любого числа с [image] также решение этой системы.

2. Если [image] и [image] являются решениями однородной системы, то и их сумма [image] также будет решением этой системы.

Отсюда следует, что всякая линейная комбинация [image] решений однородной системы линейных уравнений также является решением этой системы. Представляет интерес найти такие решения однородной системы, через которые линейно выражались бы все остальные ее решения. Набор таких решений называется фундаментальной системой решений однородной системы линейных уравнений. Фундаментальная система решений однородной системы уравнений с n неизвестными состоит из n – r решений, где r – ранг матрицы системы. Для ее нахождения последовательно каждой свободной неизвестной присваивается единичное значение, а остальным свободным неизвестным нулевое значение.

Пример. Найти фундаментальную систему решений однородной системы линейных уравнений

Решение. Приводим к ступенчатому виду основную матрицу системы:

~ [image] ~ [image] .

Количество основных неизвестных системы равно рангу r матрицы системы и равно 2, количество свободных неизвестных равно [image] .

Записываем систему уравнений, соответствующую полученной матрице:

Определитель при неизвестных х1, х2 отличен от нуля: . Неизвестные х1 , х2 будут основными, а х3, х4 – свободными. Переносим свободные неизвестные х3, х4 в правые части уравнений:

Для получения фундаментальной системы решений l1, l2 последовательно присваиваем одной свободной неизвестной единичное значение, а другой нулевое значение.

При x3 = 1, x4 = 0 система принимает вид: откуда x1 = 8, x2 = –6, т.е. получаем решение [image] .

При x3 = 0, x4 = 1 система принимает вид: откуда x1 = –7, x2 = 5, т.е. получаем решение [image] .

Найденные решения l1, l2 образуют фундаментальную систему.

Зная фундаментальную систему решений l1 , l2 , …, lk однородной системы, ее общее решение можно представить в виде: c1 + c2 + … + ck, где c1, c2, …, ck – произвольные постоянные.

Так, общее решение системы [image] можно записать в виде [image] .

Определение. Однородная система уравнений, полученная из неоднородной системы заменой всех ее свободных членов нулями, называется соответствующей однородной системой для данной неоднородной системы.

Теорема. Общее решение неоднородной системы уравнений равно сумме какого-либо его частного решения и общего решения соответствующей однородной системы.

Это утверждение иногда используется для решения неоднородных систем уравнений.

Пример. Найти общее решение системы уравнений [image] как сумму его частного решения с общим решением соответствующей однородной системы.

Решение. Приводим к ступенчатому виду расширенную матрицу системы:

~ [image] ~ [image] ~ [image] .

Система совместна и неопределенна. Количество основных неизвестных системы равно рангу r матрицы системы и равно 2, количество свободных неизвестных равно [image] .

Записываем систему уравнений, соответствующую полученной матрице:

Определитель при неизвестных х2, х3 отличен от нуля: . Неизвестные х2, х3 будут основными, а х1 , х4, х5 – свободными. Переносим свободные неизвестные х1, х4, х5 в правые части уравнений:

Частное решение неоднородной системы найдем, присваивая свободным неизвестным нулевое значение, т.е. . Получаем систему: . Решая ее, находим x2 = 2, x3 = 1. Таким образом, частное решение неоднородной системы уравнений: .

Записываем соответствующую однородную систему уравнений:

Находим фундаментальную систему решений l1 , l2 , l3 однородной системы. Для ее нахождения последовательно каждой свободной неизвестной присваиваем единичное значение, а остальным свободным неизвестным нулевое значение.

При x1 = 1, x4 = 0, x5 = 0 система принимает вид: откуда x2 = 2, x3 = 0, т.е. получаем решение [image] .

При x1 = 0, x4 = 1, x5 = 0 система принимает вид: откуда x2 = 13, x3 = 5, т.е. получаем решение [image] .

При x1 = 0, x4 = 0, x5 = 1 система принимает вид: откуда x2 = 1, x3 = –1, т.е. получаем решение [image] .

Таким образом, общее решение однородной системы уравнений:

Тогда, общее решение неоднородной системы уравнений имеет вид:


3.1. Основные понятия и определения

Определение. Геометрическим вектором называется направленный отрезок.

Вектор с началом в точке А и концом в точке В обозначается символом [image]. Также вектор обозначается одной строчной буквой со стрелкой, например [image].

Длина отрезка АВ называется длиной (или модулем) вектора [image], и обозначается [image]. Длина вектора [image] обозначается [image].

Определение. Векторы называются равными, если они имеют равные длины и одинаковые направления.

Из определения равенства векторов следует, что вектор можно переносить параллельно самому себе, а начало вектора помещать в любую точку пространства. Множество равных векторов называется свободным вектором. Именно понятие свободного вектора лежит в основе векторной алгебры.

Вектор, длина которого равна нулю, называется нулевым вектором и обозначается [image]. Нулевой вектор не имеет направления. Вектор, длина которого равна единице, называется единичным вектором и обозначается [image]. Единичный вектор, направление которого совпадает с направлением вектора [image], называется ортом вектора [image].

Два ненулевых вектора называются противоположными, если они имеют одинаковую длину и противоположные направления. Вектор, противоположный вектору [image], обозначается [image]; вектор, противоположный вектору [image], обозначается [image].

Определение. Два вектора называются коллинеарными, если они лежат на одной прямой или на параллельных прямых.

Нулевой вектор считается коллинеарным любому вектору.

Определение. Три вектора называются компланарными, если они лежат в одной плоскости или в параллельных плоскостях.

Если среди трех векторов хотя бы один нулевой или два коллинеарных, то такие векторы компланарные.


3.2. Линейные операции над векторами

Под линейными операциями над векторами понимают сложение векторов и умножение вектора на число.

Определение. Суммой векторов [image] и [image] называется вектор, соединяющий начало вектора [image] с концом вектора [image], отложенного от конца вектора [image].

Данное правило сложения векторов называется «правилом треугольника». Очевидно, что вектором [image] + [image] также будет диагональ параллелограмма, построенного на векторах [image] и [image] («правило параллелограмма»).

Сложение векторов обладает следующими свойствами:

1. + [image] = [image] + [image] (коммутативность сложения).

2. (ассоциативность сложения).

3. + [image] = [image] + [image] = [image].

4. + (– [image]) = – [image] + [image] = [image].

Так как для любого ненулевого вектора существует противоположный вектор, то можно ввести операцию вычитания векторов [image] и [image], определенную как сумма вектора [image] и вектора противоположного к вектору [image]: .

Легко убедиться в том, что в параллелограмме, построенном на векторах [image] и [image], вторая диагональ представляет разность векторов [image] и [image].

Определение. Произведением вектора [image] на число k называется вектор k [image] , длина которого равна [image], а направление совпадает с вектором [image], если k > 0, и вектора – [image], если k < 0.

Из определения произведения вектора на число следует, что два ненулевых вектора [image] и [image] будут коллинеарными только тогда, когда один из них есть произведение другого на некоторое число, например [image].

Произведение вектора на число обладает следующими свойствами:

1. (дистрибутивность умножения относительно сложения векторов).

2. (k1 + k2) [image] = k1 [image] + k2 [image] (дистрибутивность умножения относительно сложения чисел).

3. k1(k2 [image]) = (k1k2) [image] (ассоциативность).

4. 1 · [image] = [image].

Свойства линейных операций над векторами позволяют проводить линейные преобразования с векторами так, как это делается в обычной алгебре: слагаемые менять местами, вводить скобки, группировать, выносить за скобки как скалярные, так и векторные общие множители.


3.3. Разложение векторов. Базис системы векторов

Используя линейные операции над векторами, можно одни векторы выражать через другие.

Определение. Линейной комбинацией векторов [image], [image], ..., [image] c коэффициентами k1, k2, ..., kn называется вектор [image].

Представление вектора [image] в линейной комбинации векторов [image], [image], ..., [image] называется разложением вектора [image] по векторам [image], [image], ..., [image].

Теорема. Любой вектор [image] плоскости однозначно представляется в виде линейной комбинации двух неколлинеарных векторов [image], [image], т.е. . Любой вектор [image] пространства однозначно представляется в виде линейной комбинации трех некомпланарных векторов [image], [image], [image], т.е. .

Заметим, что любой вектор можно представить в виде линейной комбинации n векторов, среди которых содержится неколлинеарная (некомпланарная) система векторов. Однако при этом нарушается единственность представления.

Пример. В треугольнике АВС точка М - середина стороны ВС. Разложить вектор [image] по векторам [image] и [image].

Решение. Достроим треугольник АВС до параллелограмма АВDС.

Определение. Любая упорядоченная пара неколлинеарных векторов называется базисом плоскости. Любая упорядоченная тройка некомпланарных векторов называется базисом пространства.

Заметим, что базис это именно упорядоченная система векторов. При изменении порядка векторов изменяется также базис.

Если [image] – базис и вектор [image], то числа k1, k2, k3 называются координатами вектора [image] в базисе [image]. В силу единственности разложения вектора по базису каждый вектор однозначно определяется координатами в некотором базисе. Отсюда следует, что векторы [image] и [image] равны только тогда, когда равны их соответствующие координаты. Также очевидно, что нулевой вектор имеет все нулевые координаты, а вектор, противоположный данному, – противоположные по знаку координаты. Часто вектор [image] с координатами k1, k2, k3 записывают в виде [image].

Теорема. В любом фиксированном базисе при сложении векторов их соответствующие координаты складываются, при умножении вектора на число координаты умножаются на это число.

Так, если [image], [image], то [image] = [image] – [image] = [image] – [image] = [image].

Фиксируя базис, можно упростить разложение.

Пример. В параллелограмме АВСD точки М и N – середины сторон ВС и CD соответственно. Разложить вектор [image] по векторам [image] и [image].

Решение. Зафиксируем базис [image], [image]. Разложим векторы [image], [image] и [image] по базису [image]:

, [image], [image].

Разложить вектор [image] по векторам [image] и [image] – значит, представить его в виде: = k1 [image] + k2 [image], где k1, k2 – некоторые числа. В базисе [image] это равенство имеет вид:

= [image] + [image] или [image] = [image] + [image].

Приравнивая коэффициенты при базисных векторах [image], [image], получаем систему уравнений:

Решая систему, находим [image], [image], т.е. .

Сформулируем критерий коллинеарности и компланарности векторов в координатной форме.

Если в базисе [image] вектор [image], вектор [image], то векторы [image] и [image] будут коллинеарными только тогда, когда их соответствующие координаты будут пропорциональными, т.е. .

Если в некотором базисе [image] вектор [image], [image], [image], то векторы [image], [image] и [image] будут компланарными только тогда, когда определитель, составленный из координат этих векторов, будет равен нулю, т.е. .

Пример. Показать, что векторы [image], [image], [image] образуют базис пространства.

Решение. Три вектора образуют базис пространства только тогда, когда они являются некомпланарными векторами. Вычисляем определитель, составленный из координат векторов [image], [image], [image]:

.

Так как определитель не равен нулю, то векторы [image], [image], [image] являются некомпланарными, следовательно, образуют базис пространства.

Из всего многообразия базисов выделяют ортонормированный базис.

Определение. Базис называется ортонормированным, если он образован единичными взаимно перпендикулярными векторами.

Векторы ортонормированного базиса плоскости обозначают [image], пространства – [image]. Ортонормированный базис можно получить, отложив на каждой координатной оси декартовой системы координат по единичному вектору.


3.4. Проекция вектора на ось

Осью l называется направленная прямая. Проекцией точки M на ось l называется основание M1 перпендикуляра MM1, опущенного из точки на ось.

Пусть [image] – произвольный ненулевой вектор. Обозначим через А1 и В1 проекции на ось l соответственно начала А и конца В вектора [image].

Определение. Векторной проекцией вектора [image] на ось l называется вектор [image], началом А1 и концом В1 которого являются проекции соответственно начала А и конца В вектора [image] на данную ось.

Определение. Алгебраической проекцией вектора [image] на ось l называется положительное число [image], если направление вектора [image] совпадает с направлением оси l, и отрицательное число – [image] в противном случае. Если точки А1 и В1 совпадают ( [image] = [image]), то проекция вектора [image] на ось l равна нулю.

Обозначается алгебраическая проекция вектора [image] на ось l как [image].

Алгебраическая проекция вектора на ось обладает следующими свойствами:

1. Проекция вектора на ось равна произведению модуля вектора на косинус угла между вектором и осью, т.е. .

2. Проекция суммы векторов на ось равна сумме их проекций на эту ось, т.е. .

3. При умножении вектора на число, его проекция умножается на это число, т.е. .

Рассмотрим вектор [image] в ортонормированном базисе. Координаты вектора [image] есть его проекции на соответствующие базисные векторы: , [image], [image]. Тогда координаты любой точки М в декартовой системе координат Oxyz равны координатам вектора [image]. Вектор [image] называется радиус-вектором точки М и обозначается [image].

Найдем координаты вектора [image], если известны координаты точек [image] и [image]. = [image] = [image] – [image] = [image]. Следовательно, координаты вектора [image] равны разностям соответствующих координат его конца В и начала А.

По формуле вычисления проекции вектора на ось имеем: , [image], [image], где α, β, γ – углы, которые образует вектор [image] с базисными векторами [image]. Отсюда следует, что [image], [image], [image]. Числа cosα, cosβ, cosγ называются направляющими косинусами вектора [image]. При этом верна следующая формула: . Направляющие косинусы полностью определяют направление вектора в ортонормированном базисе.


3.5. Скалярное произведение двух векторов

Определение. Скалярным произведением двух векторов называется число (скаляр), равное произведению длин этих векторов на косинус угла между ними.

Скалярное произведение векторов [image] и [image] обозначается как [image] · [image].

Скалярное произведение двух векторов обладает следующими свойствами:

1. · [image] = [image] · [image] (коммутативность умножения).

2. · [image] = [image] (дистрибутивность умножения относительно сложения векторов).

3. .

4. Если скалярное произведение двух ненулевых векторов [image] и [image] равно нулю, то векторы [image] и [image] будут перпендикулярными. В этом случае векторы [image] и [image] называются ортогональными. Справедливо и обратное утверждение: если векторы перпендикулярны, то их скалярное произведение равно нулю.

5. Скалярный квадрат вектора равен квадрату его длины, то есть [image]. Отсюда следует, что [image].

Данная формула позволяет находить длину вектора, зная его координаты в любом базисе. Так, если [image], [image], [image], [image], то

= [image] = [image] = [image] = [image] = [image].

Найдем скалярное произведение двух векторов и длину вектора в ортонормированном базисе [image]. Учитывая свойства скалярного произведения векторов, можно определить, что [image], [image].

Тогда [image] = [image] = [image], т.е. скалярное произведение двух векторов в ортонормированном базисе равно сумме произведений их соответствующих координат.

, т.е. модуль вектора в ортонормированном базисе равен квадратному корню из суммы квадратов его координат.

Скалярное произведение двух векторов имеет определенный физический смысл.

Пусть на материальную точку М действует сила [image], под действием которой точка перемещается из положения А в положение В. Тогда скалярное произведение [image] определяет работу этой силы по перемещению точки из А в В, т.е. .

Пример. Вычислить работу силы [image] по перемещению материальной точки из А(2; 4; 6) в В(4; 2; 7).

Решение. Находим вектор перемещения: . Тогда работа [image].

Скалярное произведение двух векторов широко применяется и для решения геометрических задач: нахождения угла и вычисления проекции вектора на ось.

Так как [image], то [image].

Пример. Даны вершины треугольника A(1; 1; 1), B(2; 2; 1), C(2; 1; 2). Найти внутренний угол А треугольника.

Решение. Внутренний угол А треугольника равен углу между векторами [image] и [image]. .

, [image], [image].

Тогда [image]. Значит, внутренний угол А треугольника равен 60º.

Формуле скалярного произведения векторов [image] и [image] можно придать другой вид. Так как [image], [image], то [image]. Отсюда, [image], [image].

Пример. Найти проекцию вектора [image] на вектор [image], если [image], [image], [image].

Решение.

.

.

.

Следовательно, [image].


3.6. Векторное произведение двух векторов

Введем сначала понятие ориентации для системы трех векторов.

Определение. Три некомпланарных вектора [image], [image] и [image], взятые в указанном порядке, образуют правую тройку, если с конца вектора [image] кратчайший поворот от первого вектора [image] ко второму вектору [image] виден совершающимся против часовой стрелки, и левую, если по часовой стрелке.

Заметим, что ортонормированный базис [image] всегда будет считаться правым.

Определение. Векторным произведением двух векторов [image] и [image] называется вектор [image], определяемый условиями:
1) вектор [image] перпендикулярен векторам [image] и [image], т.е. , [image];
2) длина вектора [image] равна произведению длин векторов [image] и [image] на синус угла между ними, т.е. ;
3) векторы [image], [image] и [image] образуют правую тройку.

Векторное произведение векторов [image] и [image] обозначается как [image].

Векторное произведение двух векторов обладает следующими свойствами:

1. = [image] (антикоммутативность умножения).

2. = [image] (левая дистрибутивность умножения относительно сложения векторов).

3. = [image] (правая дистрибутивность умножения относительно сложения векторов).

4. .

5. Если векторное произведение двух ненулевых векторов [image] и [image] равно нулю, то векторы [image] и [image] будут коллинеарными. Справедливо и обратное утверждение: если векторы коллинеарны, то их векторное произведение равно нулю. Отсюда, в частности, следует, что [image].

Найдем векторное произведение двух векторов в ортонормированном базисе [image]. Векторное произведение любого базисного вектора на самого себя есть нулевой вектор, т.е. . Произведение разных базисных векторов есть третий вектор со знаком &$171;плюс» или «минус». Чтобы не ошибиться со знаком, удобно пользоваться следующей схемой:

векторное произведение двух последовательно стоящих векторов ортонормированного базиса равно следующему за ними вектору; при этом если движение осуществляется слева направо, то знак векторного произведения положительный, в противном случае – отрицательный. Например, [image], [image].

Тогда [image] = [image] = [image] = [image] = [image].

Таким образом, векторное произведение двух векторов в ортонормированном базисе равно определителю третьего порядка, первая строка которого – базисные векторы, вторая строка – координаты первого вектора, третья – второго вектора.

Пример. Найти векторное произведение векторов [image] и [image].

Решение.

.

Векторное произведение двух векторов, так же как и скалярное произведение, имеет определенный физический смысл.

Пусть на материальную точку М действует сила [image] и задана некоторая точка О. Тогда, векторное произведение вектора [image] на вектор [image] определяет момент силы [image] относительно точки О, т.е. .

Пример. Найти момент силы [image], действующей на материальную точку M(1; 2; 3), относительно точки О(3; 2; -1).

Решение.

.

.

Векторное произведение двух векторов имеет и определенный геометрический смысл.

По определению векторного произведения векторов [image] и [image] [image], т.е. модуль векторного произведения равен площади параллелограмма, построенного на векторах [image] и [image]: . Соответственно, площадь треугольника, построенного на векторах [image] и [image], будет равна одной второй модуля векторного произведения векторов [image] и [image], т.е. .

Пример. Найти площадь параллелограмма, построенного на векторах [image] и [image], если [image], [image], [image].

Решение. = [image] + [image] = [image].

.

Пример. Найти площадь треугольника с вершинами А(1; 2; 0), В(3; 0; -3), С(5; 2; 6).

Решение. , [image].
Тогда [image] и [image].
Следовательно, [image].


3.7. Смешанное произведение трех векторов

Определение. Смешанным произведением трёх векторов [image], [image] и [image] называется число, равное скалярному произведению векторного произведения векторов [image] и [image] на вектор [image], т.е. .

Смешанное произведение векторов обладает следующими свойствами:

1. Смешанное произведение не меняется при перестановке знаков скалярного и векторного умножения, т.е. . Это позволяет записывать смешанное произведение в виде [image] без знаков скалярного и векторного умножения.

2. Смешанное произведение меняет знак при перемене мест любых двух векторов-сомножителей, т.е. .

3. .

4. .

5. Если смешанное произведение трех ненулевых векторов [image], [image] и [image] равно нулю, то векторы [image], [image] и [image] будут компланарными. Справедливо и обратное утверждение: если векторы компланарны, то их смешанное произведение равно нулю. Отсюда, в частности, следует, что смешанное произведение трех векторов, из которых два коллинеарные, равно нулю.

Найдём смешанное произведение трех векторов в ортонормированном базисе [image].

.

Таким образом, смешанное произведение трех векторов в ортонормированном базисе равно определителю третьего порядка, первая строка которого – координаты первого вектора, вторая строка – координаты второго вектора, третья – третьего вектора.

Пример. Найти смешанное произведение векторов [image], [image] и [image].

Решение. .

Смешанное произведение трех векторов имеет определенный геометрический смысл: объём параллелепипеда, построенного на векторах [image], [image] и [image] равен модулю смешанного произведения этих векторов, т.е. . Соответственно, объём треугольной пирамиды, построенной на векторах [image], [image] и [image], равен одной шестой модуля смешанного произведения этих векторов, т.е. .

Пример. Найти объём пирамиды с вершинами A(1; 2; 3), B(0; -1; 1), C(2; 5; 2), D(3; 0; -2).

Решение.

, [image], [image].

.

.

Помимо нахождения объемов тел, смешанное произведение трех векторов применяется для установления компланарности векторов и определения взаимной ориентации векторов в пространстве: если смешанное произведение трех векторов равно нулю, то векторы будут компланарными; если смешанное произведение трех векторов больше нуля, то векторы образуют правую тройку, меньше нуля – левую тройку.


4.1. Множества и операции над ними

Под множеством понимают совокупность объектов, объединенных по некоторому признаку. Так, можно говорить о множестве студентов ВУЗа, о множестве корней уравнения [image] и т.д.

Объекты, из которых составлено множество, называются его элементами. Как правило, множество обозначается прописной буквой, а его элементы строчными буквами. Тот факт, что элемент a принадлежит множеству A, записывается, как [image]. Запись [image] означает, что a не является элементом множества А.

Множества называются равными, если они состоят из одних и тех же элементов. Множество, не содержащее ни одного элемента, называется пустым и обозначается [image].

Множество обычно задают или перечислением всех его элементов, или указанием характеристического свойства его элементов. В первом случае все элементы множества записываются в фигурных скобках, например [image]. Если же множество задается свойством P его элементов, то пишут [image], например [image]. Для некоторых множеств приняты стандартные обозначения, которых стоит придерживаться. Так буквами N, Z, Q, R обозначают соответственно множество натуральных чисел, множество целых чисел, множество рациональных чисел и множество действительных чисел. Множество натуральных чисел от 1 до n, т.е. обозначают [image].

Если каждый элемент множества B является элементом множества A, то говорят, что B есть подмножество множества A, и пишут [image]. В частности, подмножеством любого множества является само это множество и пустое множество.

Введем следующие операции над множествами.

Определение. Объединением множеств А и В называется множество [image], состоящее из всех тех элементов, каждый из которых принадлежит хотя бы одному из множеств А, В:

.

Определение. Пересечением множеств А и В называется множество [image], состоящее из всех тех элементов, которые содержатся в обоих множествах А, В:

.

Если пересечение множеств окажется пустым множеством, то исходные множества называются непересекающимися.

Операции объединения и пересечения множеств обладают следующими свойствами:

1. (коммутативность объединения).

2. (ассоциативность объединения).

3. = А.

4. (коммутативность пересечения).

5. (ассоциативность пересечения).

6. = [image].

7. (дистрибутивность пересече-ния относительно объединения).

8. (дистрибутивность объедине-ния относительно пересечения).

Определение. Разностью множеств А и В называется множество [image], состоящее из всех элементов множества А, не содержащихся в множестве В:

.

В том случае, когда [image] множество [image] называется дополнением множества В до множества А. Дополнение множества В обозначается [image].

Определение. Декартовым произведением множеств А и В называется множество [image], состоящее из всех пар вида [image], в которых первый элемент принадлежит множеству А, а второй – множеству В:

.

Если множество А содержит m элементов, а множество B содержит n элементов, то декартовое произведение [image] содержит [image] элементов.

Обобщая декартовое произведение на случай n множеств, имеем:

.

В том случае, когда [image], получаем декартовую n-ую степень множества А:


4.2. Отображения множеств

Определение. Отображением множества А в множество В называется всякое правило f, по которому каждому элементу множества А сопоставляется вполне определенный (единственный) элемент множества В.

Для обозначения отображения f множества А в множество В используется запись: .

Заметим, что отображение f множества А в множество В называется также функцией, заданной на множестве А со значениями в множестве В.

Если элементу [image] поставлен в соответствие элемент [image] (это записывается в виде [image]), то b называется образом элемента а, а элемент а – прообразом элемента b при отображении f.

Из определения отображения f следует, что у каждого элемента [image] существует единственный образ. Однако для элемента [image] прообразов может быть несколько, а может и вообще не быть. Множество всех прообразов элемента b называется его полным прообразом и обозначается через [image]:

.

Например, рассмотрим множество [image] и отображение [image], сопоставляющее каждому элементу [image] остаток от деления а на число 4. Тогда f(0) = 0, f(1) = 1, f(2) = 2, f(3) = 3, f(4) = 0, f(5) = 1, f(6) = 2. Следовательно, [image], [image], [image], [image], [image] = [image] = [image] = Ø.

В зависимости от свойств образов и прообразов различают отображения сюръективные, инъективные и биективные.

Определение. Отображение [image] называется сюръективным, если каждый элемент из множества В является образом хотя бы одного элемента из множества А.

Отображение [image] называется инъективным, если разным элементам множества А ставятся в соответствие разные элементы множества В, т.е. из условия [image] следует, что [image].

Отображение [image] называется биективным или взаимнооднозначным, если оно является сюръективным и инъективным.

Например, рассмотрим отображение [image] (N0 – множество целых неотрицательных чисел), в котором каждому числу [image] сопоставляется абсолютна величина числа а. Данное отображение является сюръективным, но не является инъективным так как элементам а и –а ставится в соответствие один и тот же элемент. Однако, если таким же образом определить отображение N в N, то получим биективное отображение. Таким образом, изменив множества А, В, можно получить отображение с другими свойствами.

Определение. Отображение множества А в себя, т.е. , называется преобразованием множества А. Биективное преобразование множества А называется подстановкой множества А. Подстановка [image], переводящая каждый элемент [image] в себя, т.е. , называется тождественной или единичной.

Примером единичного отображения может служить отображение [image] в котором [image].

В теории и на практике часто приходится осуществлять последовательно различные отображения множеств.

Определение. Композицией (или произведением) отображений [image] и [image] называется отображение [image], определяемое условием [image] для любого [image].

Например, рассмотрим отображения: в котором [image] и [image], в котором [image]. Композицией отображений f и g будет отображение [image], в котором [image].

Композиция отображений обладает следующими свойствами:

1. Композиция отображений не является коммутативной, т.е. . Так, для приведенных выше отображений, композицией g и f будет отображение, в котором [image].

2. Композиция отображений является ассоциативной, т.е. если [image], [image], [image], то [image].

3. Если отображения [image] и [image] являются сюрьективными, инъективными или биективными, то соответственно таким же будет и композиция этих отображений. Заметим, что обратное утверждение в общем случае неверно.

В случае биективного отображения [image] можно определить отображение [image], в котором для любого [image] [image] только тогда, когда [image]. Отображение g в это случае называется обратным к f. Приведем более строгое определение обратного отображения.

Определение. Отображение [image] называется обратным к отображению [image], если [image] и [image], т.е. композиции отображений f и g в любом порядке являются единичными отображениями.

Отображение обратное к отображению f обозначается f–1.

Теорема. Отображение [image] имеет обратное только тогда, когда оно является биективным.


4.3. Бинарные алгебраические операции

Определение. Бинарной алгебраической операцией на множестве М называется отображение множества М2 во множество М.

Таким образом, любой упорядоченной паре (а; b) элементов [image] ставится в соответствие однозначно определенный элемент того же множества М. Известные из средней школы правила сложения и умножения чисел задают бинарные операции на любом из множеств N, Z, Q, R. Вычитание же чисел задает бинарную операцию на множествах Z, Q, R и не задает операции на множестве N.

Элемент, сопоставляемый отображением f паре (а; b) называется значением операции f на паре (а; b), и обозначается через f(a; b) или аfb. Однако чаще всего бинарную операцию обозначают каким-нибудь символом: и т.п.

Заметим, что в алгебре рассматриваются также и nарные операции, являющиеся отображениями множества Mn в М.

В связи с большим разнообразием операций их классифицируют по свойствам.

Определение. Бинарная операция * на множестве М называется коммутативной, если для любых элементов [image] выполняется равенство: а*b = b*а. Бинарная операция * на множестве М называется ассоциативной, если для любых элементов [image] выполняется равенство: .

Отметим, что для отдельных элементов [image] равенство а*b = b*a может выполняться и в том случае, когда операция * не является коммутативной. Такие элементы называются перестановочными друг с другом. Главная роль свойства ассоциативности заключается в том, что оно позволяет не расставлять скобки при оперировании со многими элементами. Свойства коммутативности и ассоциативности операций независимы, т.е. существуют операции, обладающие любым одним из этих свойств и не обладающие другим. Примером коммутативной, но не ассоциативной операции на множестве R может служить операция нахождения среднего арифметического: .

В том случае, когда на одном и том же множестве определены несколько операций, можно говорить о свойствах, связывающих различные операции.

Определение. Бинарная операция * на множестве М называется лево или право дистрибутивной относительно операции [image], если для любых элементов [image] выполняется соответственно равенство: или [image].

Если выполняются оба этих свойства, то говорят просто о дистрибутивности операции * относительно операции [image]. В частности, если операция * коммутативная, то левая (правая) дистрибутивность совпадает с дистрибутивностью. В числовых множествах операция умножения чисел является дистрибутивной относительно сложения чисел, а операция сложения чисел не является дистрибутивной относительно умножения чисел.

Известно, что при сложении чисел, число 0 играет особую роль: сумма любого числа а и 0 равна а. При умножении чисел аналогичную роль играет 1: произведение любого числа а и 1 равно а. Обобщим понятие таких элементов для любой бинарной операции.

Определение. Элемент [image] называется нейтральным относительно бинарной операции * на множестве М, если для любого элемента [image] выполняются равенства: а*λ = λ*а = а.

Разумеется, не всякая бинарная операция на множестве имеет нейтральный элемент. Например, рассмотрим операцию умножения [image] на множестве четных натуральных чисел. При любых а, b принадлежащих этому множеству произведение аb является четным числом, т.е. является бинарной операцией. Но нейтрального элемента операция на данном множестве не имеет.

Теорема. Если нейтральный элемент для бинарной операции существует, то он единственный.

С нейтральным элементом связано еще одно понятие.

Определение. Элемент [image] называется симметричным для элемента [image] относительно бинарной операции * на множестве М, если выполняются равенства : а* [image] = [image] *а = λ, где λ – нейтральный элемент.

Так относительно операции сложения на множестве Z симметричным к данному числу а является то же число, взятое со знаком минус, т.е. –а; относительно операции умножения на множестве Q симметричным к ненулевому числу а является число [image] (число 0 не имеет симметричного элемента относительно операции умножения).

В общем случае элемент множества может не иметь симметричных элементов и может иметь один или несколько симметричных элементов. Более определено вопрос о числе симметричных элементов решается для ассоциативных бинарных операций.

Теорема. Если для элемента относительно ассоциативной бинарной операции существует симметричный элемент, то он единственный.

В заключение параграфа сделаем одно замечание по терминологии и обозначениям.

Суть операции и ее свойства совершено не зависят от ее обозначения и названия. В связи с этим при изучении множеств с операциями последние чаще всего обозначают +, · и называют соответственно сложением и умножением. Употребляемую при этом терминологию и форму записи называют соответственно аддитивной и мультипликативной.

При аддитивной форме записи результат операции называют суммой и обозначают а + b. Нейтральный элемент относительно сложения обозначают 0, и называют нулевым элементом. Элемент, симметричный элементу а, обозначают –а и называют противоположным элементу а.

При мультипликативной форме записи результат операции называют произведением и обозначают а·b или аb без всякого знака операции между а и b. Нейтральный элемент относительно умножения обозначают е или 1, и называют единичным элементом. Элемент, симметричный элементу а, обозначают а– и называют обратным элементу а.


4.4. Алгебраические структуры с одной операцией

Множество, наделенное системой операций, называется алгебраической структурой или алгеброй. В принципе можно рассматривать любые алгебраические структуры. Однако практический интерес представляют алгебраические структуры с одной и двумя бинарными операциями, удовлетворяющими определенным условиям.

Определение. Непустое множество М с заданной на нем одной бинарной алгебраической операцией * называется группоидом и обозначается (М; *).

В случае, когда множество М конечно, группоид (М; *) можно задать квадратной таблицей, называемой таблицей Кэли (в честь английского математика А. Кэли). Во входной строке и во входном столбце этой таблицы выписываются все элементы множества М; результат же применения операции * к элементам а, b записывается на пересечении строки с входным элементом а и столбца с входным элементом b.

Группоиды с коммутативной операцией называются коммутативными. Очевидно, что коммутативность группоида равносильна симметричности его таблицы Кэли относительно главной диагонали.

Группоиды с ассоциативной операцией называются ассоциативными или полугруппами. Полугруппу, имеющую нейтральный элемент называют моноидом.

Определение. Группоид (G; *) называется группой, если 1) бинарная операция * ассоциативна; 2) на множестве G для бинарной операции * существует нейтральный элемент; 3) для каждого элемента [image] существует симметричный элемент относительно операции *.

Таким образом, группа – это моноид, для каждого элемента которого существует симметричный элемент.

Если, кроме того, бинарная операция * коммутативна, то группа называется коммутативной или абелевой (в честь норвежского математика Абеля). Для абелевых групп чаще всего применяется аддитивная форма записи.

Примерами групп являются группоиды (Z; +), (Q; +), (R; +). Все эти группы – абелевы. Нейтральным элементом в них является число 0, а симметричным числу а – противоположное число –а. Группоиды (Z; ·), (Q; ·), (R; ·) группами не являются, так как не для всех элементов существует симметричный элемент (например, для 0). Исключив из множеств Q и R число 0, мы получим группоиды, которые будут являться группами относительно операции умножения.

При решении практических задач, многие из них сводятся к решению уравнений и систем уравнений. Рассмотрим на множестве M с бинарной операцией * решение уравнений [image] и [image], где неизвестным является элемент x. Эти уравнения имеют решения только в том случае, если для элемента а существует симметричный элемент [image] относительно операции *. Тогда, для первого уравнения решением является элемент [image], для второго – [image] (докажите это самостоятельно). В общем случае уравнения имеют или одно решение или несколько решений. Для групп же справедливо следующее утверждение.

Теорема. В группе (G; *) для любых элементов [image] каждое из уравнений [image] и [image] имеет единственное решение.

Если группа является коммутативной, уравнения [image] и [image] есть одно и то же уравнение, решением которого является элемент [image].

Рассмотрим коммутативную группу с операцией сложения. Решением уравнений a + x = b и x + a = b будет элемент x = b + (–a) который обозначим b – а и назовем разностью элементов b и a. Таким образом, в абелевой группе можно определить ещё одну операцию: вычитание.


4.5. Алгебраические структуры с двумя операциями

Определение. Множество K на котором заданы две бинарные операции, называемые обычно сложением и умножением, называется кольцом, если 1) относительно операции сложения группоид (К; +) является абелевой группой; 2) относительно операции умножения группоид (K; ·) является полугруппой; 3) операция умножения дистрибутивна относительно операции сложения.

При этом группоид (К; +) называется аддитивной группой кольца, а группоид (K; ·) – мультипликативной полугруппой.

Добавляя к требованиям 1)–3) в определении кольца различные дополнительные условия, получим различные частные типы колец. Так, если операция умножения является коммутативной, то кольцо называется коммутативным; если для операции умножения существует единичный элемент (этот единичный элемент называется единицей кольца), то кольцо называется кольцом с единицей.

Примерами коммутативных колец с единицей являются числовые кольца (Z; +; ·), (Q; +; ·), (R; +; ·). Примером коммутативного кольца без единицы может служить множество четных целых чисел с обычными операциями сложения и умножения чисел.

Заметим что любую абелевую группу (G; +) можно сделать кольцом, задав на ней операцию умножения следующим образом a·b = 0, где 0 – нулевой элемент относительно сложения (чтобы доказать это, достаточно проверить выполнение законов дистрибутивности). Кольцо, в котором произведение любых двух элементов равно нулевому элементу, называется кольцом с нулевым умножением.

Из определения кольца вытекает ряд свойств, хорошо известных для чисел, но так же верных для колец с множествами любой природы. Так для любых элементов a, b произвольного кольца К выполняются равенства:

1) a·0 = 0·a = 0;

2) (–a)·b = a·(–b) = –(a·b);

3) (–a)·(–b) = a·b.

При этом следует понимать, что элементы a, b могут быть элементами любой природы. Поэтому эти равенства необходимо доказывать, используя законы множеств с алгебраическими операциями. Докажем, например, равенство a·0 = 0.

Так как, по определению нулевого элемента 0 + 0 = 0, то a·0 = а·(0 + 0). Применяем закон дистрибутивности: a·0 = а·0 + а·0. Прибавив к обеим частям равенства противоположный для а·0 элемент –(а·0), получаем a·0 – (а·0) = а·0 + а·0 – (а·0), откуда 0 = а·0.

Помимо свойств, характерных для обычной алгебры, кольцо имеет ряд специфичных свойств.

Так, произведение чисел равно нулю только тогда, когда, по крайней мере, один из сомножителей равен нулю, т.е. из равенства a·b = 0 следует, что или a = 0 или b = 0. В кольце это не всегда так. В нём могут быть элементы a и b такие, что a·b = 0, но [image] и [image]. Такие элементы называются делителями нуля. Например, числовые пары (a; b) где [image] со сложением и умножением, определяемыми формулами: , [image] = [image] образуют коммутативное кольцо с нулевым элементом 0 = (0; 0). Для элементов (1; 0) и (0; 1) имеем [image], т.е. произведение двух ненулевых элементов равно нулевому элементу.

Числовые кольца (Z; +; ·), (Q; +; ·), (R; +; ·) делителей нуля не имеют. Коммутативное кольцо с единицей и без делителей нуля называется кольцом целостности (или областью целостности).

Теорема. Коммутативное кольцо с единицей К является целостным только тогда, когда в нём выполняется закон сокращения: для всех элементов [image] и [image] из равенства a·b = a·с следует, что b = c.

В коммутативных кольцах с единицей особо выделяют обратимые элементы.

Определение. Элемент a кольца К называется обратимым (или делителем единицы) если для него существует обратный элемент a–1, т.е. элемент, удовлетворяющий равенствам [image].

Так в кольце целых чисел обратимыми являются элементы –1 и 1; всякое другое целое число не имеет обратного относительно операции умножения. Множество всех обратимых элементов кольца K обозначается через K*. Тогда для числовых колец (Z; +; ·) и (Q; +; ·) Z* = {–1; 1}, Q* = Q\{0}.

Заметим, что в кольцах (Z; +; ·), (Q; +; *#183;) множества Z* и Q* являются группами относительно операции умножения. Этот факт не случаен.

Теорема. Множество всех обратимых элементов кольца с единицей является группой относительно операции умножения.

Эта группа называется мультипликативной группой кольца. При этом нулевой элемент кольца обратного элемента не имеет.

Добавив к требованиям в определении кольца дополнительное условие на обратимость элементов, получим частный тип кольца – поле.

Определение. Полем называется коммутативное кольцо с единицей, отличной от нуля, в котором каждый ненулевой элемент обратим.

Поле представляет собой гибрид двух абелевых групп – аддитивной и мультипликативной, связанных законом дистрибутивности.

Так как поля является кольцами, то они обладают всеми свойствами колец. Вместе с тем, для полей выполняются свойства, которыми обладают не все кольца.

Например, в любом поле Р отсутствуют делители нуля, т.е. для любых элементов [image] из равенства а*#183;b = 0 следует, что или а = 0, или b = 0.

Рассмотрим как решаются в поле Р простейшие уравнения а + х = b и а·х = b (так как операции сложения и умножения в поле являются коммутативными, то достаточно рассмотреть только два уравнения). Так как группоид (Р; +) есть абелева группа, то уравнение а + х = b имеет единственное решение х = b + (–а), которое, напомним, обозначается через b–а и называется разностью элементов b и а. Группоид (P; ·) так же является абелевой группой. Следовательно, для любых элементов [image] и [image] уравнение а·х = b имеет единственное решение х = а–1*·b. По аналогии с числами, элемент а–1·b записывают в виде [image] и называют частным от деления элемента b на элемент а.

Таким образом, поле есть множество, для элементов которого определены, и всегда выполнимы, операции сложения, умножения, вычитания и деления (кроме деления на 0).


5.1. Основные понятия и определения

Рассмотрим множество С, элементами z которого являются упорядоченные пары действительных чисел (а; b). Определим на множестве С операции сложения и умножения следующим образом:

z1 + z2 = (a1; b1) + (a2; b2) = (a1+a2; b1+b2),

z1 · z2 = (a1; b1) · (a2; b2) = (a1a2–b1b2; a1b2+b1a2).

Коммутативность и ассоциативность операции сложения в С следуют непосредственно из соответствующих свойств сложения в R. Нулевым элементом группоида (С; +) является пара (0; 0), а противоположным к элементу (а; b) – пара (–а; –b). Следовательно, группоид (С; +) – абелева группа. Непосредственной проверкой доказываются коммутативность и ассоциативность операции умножения в С, а также дистрибутивность умножения относительно сложения. Таким образом, алгебраическая структура (С; +; ·) – коммутативное кольцо. Так как (а; b)·(1; 0) = (a; b), то элемент (1; 0) является единичным элементом кольца (С; +; ·). Для любого ненулевого элемента z = (а; b) существует обратный элемент [image]. Следовательно, (С; +; ·) – поле.

Определение. Множество [image] с операциями сложения и умножения, определяемыми формулами z1 + z2 = (a1; b1) + (a2; b2) = (a1+a2; b1+b2), z1· z2 = (a1; b1) · (a2; b2) = (a1a2–b1b2; a1b2+b1a2) называется полем комплексных чисел. Элемент [image] называется комплексным числом.

Рассмотрим в поле комплексных чисел действия над элементами вида (а; 0): (а1; 0) + (а2; 0) = (а1 + а2; 0), (а1; 0)·(а2; 0) = (а1·а2; 0). Из этих равенств видно, что операции над парами вида (а; 0) сводятся к соответствующим операциям над их первыми компонентами. В связи с этим, естественно отождествить комплексное число (а; 0) с действительным числом а, т.е. (а; 0) = а, и тем самым включить множество действительных чисел R во множество С.

Обозначив i элемент (0; 1), можно получить новое представление для любого комплексного числа z:

z = (a; b) = (a; 0) + (0; b) = (a; 0) + (b; 0)·(0; 1) = a + bi.

Представление числа [image] в виде а + bi, где [image] называется алгебраической формой комплексного числа. При этом i называется мнимой единицей, число а называется вещественной (или действительной) частью числа z, число b – мнимой частью числа z. Те комплексные числа, действительная часть которых равно 0, т.е. числа вида z = bi называется чисто мнимыми. Два комплексных числа, отличающихся только знаком мнимой части, т.е. a + bi и a – bi называются сопряженными. Число, сопряженное к z, обозначается [image].

В новых обозначениях равенства, определяющие операции сложения и умножения комплексных чисел, примут вид:

z1 + z2 = (a1 + b1i) + (a2 + b2i) = (a1 + a2) + (b1 + b2)i;

z1 · z2 = (a1 + b1i) · (a2 + b2i) = (a1a2 – b1b2) + (а1b2 + b1а2)i.

Учитывая, что для числа a + bi противоположным является число –a–bi, а обратным – число [image] , можно определить еще операции вычитания и деления комплексных чисел:

z1 – z2 = (a1 + b1i) + (– a2 – b2i) = (a1 – a2) + (b1 – b2)i;

.

Заметим, что формулы умножения и деления комплексных чисел нет необходимости запоминать. На практике произведение комплексных чисел z1 = a1 + b1i и z2 = a2 + b2i получают перемножением двучленов a1 + b1i и a2 + b2i по правилам алгебры, учитывая, что i2 = (0; 1)·(0; 1) = (–1; 0) = –1. Частное комплексных чисел [image] находят, умножая числитель и знаменатель на число [image] сопряженное знаменателю.

Пример. Найти z1 + z2, z1 – z2, z1 · z2, [image] , если z1 = 1 + 2i, z2 = 2 – i.

Решение.

z1 + z2 = (1 + 2i) + (2 – i) = 3 + i,

z1 – z2 = (1 + 2i) – (2 – i) = –1 + 3i,

z1 · z2 = (1 + 2i)·(2 – i) = 2 – i + 4i &8211; 2i2 = 4 + 3i,

.

Поскольку i2 = –1, то на множестве комплексных чисел С разрешимо квадратное уравнение [image] , корнями которого являются числа i, –i. Отсюда можно вывести, что любое квадратное уравнение [image] с действительными коэффициентами имеет два корня из множества С.

Они находятся по формуле [image] , где [image].

Перед радикалом стоит только знак +, так как на множестве комплексных чисел [image] имеет два значения.

Пример. На множестве комплексных чисел решить уравнение [image].

Решение. .

.

Так же решаются и квадратные уравнения, коэффициенты которых комплексные числа.

Пример. Решить уравнение [image] .

Решение. , [image].

Для нахождения [image] воспользуемся следующим способом:

. Возведя в квадрат данное равенство, имеем [image] . Приравнивая действительные и мнимые части комплексных чисел, получаем систему [image] где [image]. Решая систему, находим [image], [image] , [image], [image], т.е. .

Тогда, [image] , [image] .

Заметим, что еще в XVII веке было доказано, что на множестве комплексных чисел разрешимо любое алгебраическое уравнение степени n с действительными коэффициентами, при этом оно имеет n корней. Данное утверждение получило название – основная теорема алгебры. Позже было доказано, что и в случае комплексных коэффициентов, алгебраическое уравнение степени n имеет n корней.

Отметим так же, что если алгебраическое уравнение с действительными коэффициентами имеет комплексный корень, то корнем этого же уравнения будет и сопряженное комплексное число к этому корню.


5.2. Геометрическое представление комплексных чисел

Каждому комплексному числу z = a + bi поставим в соответствие точку М плоскости с абсциссой а
 и ординатой b. Для любых двух комплексных чисел z1 = a1 + b1i и
 z2 = a2 + b2i равенство z1 = z2 верно только тогда,
 когда a1 = a2 и b1 = b2. Поэтому отображение, ставящее в
 соответствие каждому комплексному числу z = a + bi точку М(а; b) координатной плоскости, является биективным
 отображением.

Координатная плоскость, точки которой изображают комплексные числа, называется комплексной плоскостью. Действительные числа изображаются точками оси абсцисс. Поэтому ось абсцисс называется действительной осью. Точки оси ординат изображают чисто мнимые числа. Поэтому ось ординат называется мнимой осью (рис. 1).

Сопряженные комплексные числа z и [image] изображаются точками, симметричными относительно действительной оси. Взаимно противоположные числа z и –z изображаются точками, симметричными относительно начала координат.

Соединив начало координат О с точкой М(а; b) получим радиус-вектор точки М. В некоторых случаях удобно считать геометрическим представлением комплексного числа z = a + bi вектор [image].

Определение. Расстояние от начала координат комплексной плоскости до точки М(a; b), изображающей комплексное число z = a + bi, называется модулем числа z и обозначается [image] или r. Угол между положительным направлением действительной оси и вектором, изображающим комплексное число z = a + bi, называется аргументом числа z и обозначается arg z или [image].

Модуль числа z = a + bi вычисляется по формуле [image] .

Аргумент комплексного числа считается положительным, если он отсчитывается от действительной оси против часовой стрелки, и отрицательным при противоположном направлении. Аргумент числа z определяется не однозначно, а с точностью до слагаемого 2 [image] k, [image] , т.е. одному и тому же числу соответствует бесконечное множество углов. Считая, что аргумент числа z = a + bi принадлежит промежутку [image], [image] находится по формуле

, где [image] .

Например, для числа [image] модуль

, аргумент [image].

Аргумент действительных чисел z = a + 0i = a равен либо 0 (если [image] ), либо [image] (если [image] ). Аргумент чисто мнимых чисел z = bi равен либо [image] (если [image] ), либо [image] (если [image] ). Для числа z = 0 + 0i = 0 аргумент не определен.


5.3. Тригонометрическая форма комплексного числа

Наряду с алгебраической формой комплексного числа применяется тригонометрическая форма.

Действительная и мнимая части числа [image] связаны с модулем r и аргументом [image] соотношениями: , [image]. Подставив эти зависимости в алгебраическую форму, получаем следующее представление комплексного числа z: .

Такое представление комплексного числа называется тригонометрической формой.

Тригонометрическая форма комплексного числа хорошо приспособлена к операциям умножения, деления, возведения в степень и извлечения корня.

Найдем произведение двух комплексных чисел, записанных в тригонометрической форме

Таким образом, при умножении двух комплексных чисел, записанных в тригонометрической форме, модули чисел перемножаются, а аргументы складываются.

Отсюда следует, что при делении комплексных чисел, записанных в тригонометрической форме, модули чисел делятся, а аргументы вычитаются, т.е.

Распространив правило умножения комплексных чисел в тригонометрической форме на случай n равных множителей, получим формулу возведения в степень комплексного числа:

Данная формула называется формулой Муавра, в честь английского математика де Муавра.

Пример. Возвести в четвертую степень число [image].

Решение. Запишем число [image] в тригонометрической форме: .

По формуле Муавра имеем [image] [image].

Наряду с формулой возведения в степень комплексного числа де Муавром была выведена и формула извлечения корня n-ой степени из комплексного числа [image] , т.е. формула нахождения всех корней уравнения [image] .

Если [image], то по формуле Муавра получаем: .

Сравнивая в обеих частях равенства модули и аргументы, находим, что [image], [image], [image] (слагаемое 2πk – плата за неполную определенность аргумента). Отсюда следует, что [image], [image], [image], где [image] – арифметический корень n-ой степени из положительного действительного числа. Следовательно, [image], [image].

Выясним сколько среди чисел w различных. В силу периодичности косинуса и синуса имеется ровно n различных комплексных чисел. Они получаются при значениях k равных 0, 1, …, n–1. Все они лежат в вершинах правильного n-угольника, вписанного в окружность радиуса [image] с центром в начале координат.

Таким образом, для любого комплексного числа [image] существует n значений корня n-ой степени из z, которые находятся по формуле: , k = 0, 1, …, n–1.

Пример. Найти все значения [image] .

Решение. Запишем число z = 8 в тригонометрической форме: .

По формуле извлечения корня n-ой степени из комплексного числа имеем [image], k = 0, 1, 2.

Полагая k = 0, 1, 2, получаем

,

,

.

Рассмотрим подробнее множество [image] всех корней n-ой степени из единицы: , где [image], k = 0, 1,…, n–1.

Множество [image] замкнуто относительно ассоциативной операции умножения комплексных чисел, т.е. для любых чисел [image] и [image] из [image] число [image] принадлежит [image]. На множестве [image] существует единичный элемент [image] относительно операции умножения. Для каждого элемента [image] существует обратный ему элемент [image]. Из всего этого следует, что множество [image] всех корней n-ой степени из единицы с операцией умножения является группой.

Отметим одно замечательное свойство группы [image]. Из равенства [image], k = 0, 1, …, n–1 и формулы Муавра следует, что [image], т.е. все элементы множества [image] являются степенями одного её элемента [image]. Следовательно, группа [image] является циклической группой, порожденной элементом [image] .

В заключение параграфа укажем на связь корней n-ой степени из произвольного комплексного числа z с корнями n-ой степени из единицы: все корни n-ой степени из комплексного числа z представляются в виде произведения одного из них на все корни n-ой степени из единицы.


ГЛОССАРИЙ

Базисом плоскости называется любая упорядоченная пара неколлинеарных векторов.

Базисом пространства называется любая упорядоченная тройка некомпланарных векторов.

Геометрическим вектором называется направленный отрезок.

Коллинеарными называются два вектора, если они лежат на одной прямой или на параллельных прямых.

Компланарными называются три вектора, если они лежат в одной плоскости или в параллельных плоскостях.

Комплексным числом называется элемент [image] .

Матрицей размера m×n называется прямоугольная таблица из m строк и n столбцов, состоящая из чисел или иных математических выражений.

Минором k-го порядка матрицы А называется определитель матрицы k-го порядка, полученной из матрицы А вычёркиванием некоторого числа её строк и (или) столбцов.

Полем комплексных чисел называется множество [image] с операциями сложения и умножения, определяемыми формулами z1 + z2 = (a1; b1) + (a2; b2) = (a1+a2; b1+b2), z1 · z2 = (a1; b1) · (a2; b2) = (a1a2–b1b2; a1b2+b1a2)

Рангом матрицы называется наивысший порядок отличных от нуля миноров этой матрицы.

Системой линейных алгебраических уравнений, содержащей m уравнений и n неизвестных, называется система вида [image], где aij, bi (i = 1, 2, …, m; j = 1, 2, …, n) – заданные числа, называемые соответственно коэффициентами при неизвестных xj и свободными членами уравнений.

Скалярным произведением двух векторов называется число (скаляр), равное произведению длин этих векторов на косинус угла между ними.


Литература

1. Кострикин, А.И. Введение в алгебру. Часть 1. Основы алгебры: учебник для вузов / А.И. Кострикин – М.: Физматлит, 2000. – 272 с.

2. Кострикин, А.И. Введение в алгебру. Часть 2. Линейная алгебра: учебник для вузов / А.И. Кострикин – М.: Физматлит, 2000. – 368 с.

3. Глухов, М.М. Алгебра и аналитическая геометрия: учебное пособие / М.М. Глухов – М.: Гелиос АРВ, 2005. – 392 с.

4. Бугров, Я.С. Высшая математика. Элементы линейной алгебры и аналитической геометрии / Я.С. Бугров, С.М. Никольский – М.: Дрофа, 2003. – 284 с.

5. Кострикин, А.И. Сборник задач по алгебре: учебник для вузов / А.И. Кострикин – М.: Физматлит, 2001. – 464 с.

6. Минорский, В.П. Сборник задач по высшей математике: учебное пособие для втузов / В.П. Минорский. –М.: Физматлит, 2004. – 336 с.


Теоретические вопросы

Тема 1. Матрицы и определители

1. Что называется матрицей? Какая матрица называется диагональной, треугольной, ступенчатой?

2. Как определяется операция сложения матриц? Каковы ее свойства?

3. Как определяется операция умножения матрицы на число? Каковы ее свойства?

4. Как определяется операция умножения матриц? Каковы ее свойства?

5. Как определяется операция транспонирования матрицы? Каковы ее свойства?

6. Что называется элементарными преобразованиями матрицы?

7. Что называется определителем матрицы 1, 2 и 3-го порядков?

8. Что называется минором и алгебраическим дополнением элемента квадратной матрицы? Сформулируйте теорему Лапласа.

9. Укажите свойства определителя матрицы.

10. Что называется матрицей обратной по отношению к матрице А? Каково условие существования обратной матрицы?

11. Изложите алгоритм нахождения обратной матрицы, использующий алгебраические дополнения элементов матрицы.

12. Изложите алгоритм нахождения обратной матрицы, использующий элементарные преобразования матрицы.

13. Какие уравнения называются матричными? Укажите виды матричных уравнений и их решения.

14. Что называется минором k-го порядка и рангом матрицы? Укажите свойства ранга матрицы.

15. Изложите метод окаймляющих миноров вычисления ранга матрицы.

16. Изложите метод элементарных преобразований вычисления ранга матрицы и сформулируйте теоремы, на которых он базируется.

Тема 2. Системы линейных уравнений

1. Какая система уравнений называется совместной, несовместной? Сформулируйте теорему Кронекера-Капелли.

2. Какая система уравнений называется определенной, неопределенной? Сформулируйте теорему о количестве решений совместной системы.

3. Изложите матричный метод решения невырожденной системы линейных уравнений.

4. Изложите метод Крамера решения невырожденной системы линейных уравнений.

5. Изложите метод Гаусса решения определенной (неопределенной) системы линейных уравнений.

6. Что называется однородной системой линейных уравнений? В каком случае однородная система имеет ненулевое решение?

7. Что называется фундаментальной системой решений однородной системы уравнений? Изложите алгоритм ее нахождения.

8. Как связано общее решение неоднородной системы уравнений и соответствующей однородной системы уравнений?

Тема 3. Векторная алгебра

1. Что называется вектором? Какие векторы называются коллинеарными, компланарными?

2. Как определяется операция сложения векторов? Каковы ее свойства?

3. Как определяется операция умножения вектора на число? Каковы ее свойства?

4. Что называется базисом векторов на плоскости, в пространстве? Какой базис называется ортонормированным?

5. Что такое координаты вектора в данном базисе? Как осуществляются линейные операции над векторами, заданными в координатной форме?

6. Изложите критерий коллинеарности и компланарности векторов в координатной форме.

7. Что называется алгебраической проекцией вектора на ось? Укажите ее свойства.

8. Какова связь между координатами вектора в ортонормированном базисе и проекциями этого вектора на соответствующие базисные векторы?

9. Что называется скалярным произведением двух векторов? Укажите его свойства.

10. Изложите приложения скалярного произведения двух векторов.

11. Что называется векторным произведением двух векторов? Укажите его свойства.

12. Изложите приложения векторного произведения двух векторов.

13. Что называется смешанным произведением трех векторов? Укажите его свойства.

14. Изложите приложения смешанного произведения трех векторов.

15. Как вычисляются скалярное, векторное и смешанное произведения векторов в ортонормированном базисе?

Тема 4. Алгебраические структуры

1. Что понимают под множеством? Как задаются множества?

2. Как определяется операция объединения множеств? Каковы ее свойства?

3. Как определяется операция пересечения множеств? Каковы ее свойства?

4. Что называется разностью, декартовым произведением множеств?

5. Что называется отображением множества. Какое отображение называется сюръективным, инъективным, биективным?

6. Что называется бинарной алгебраической операцией на множестве? Какая бинарная операция называется коммутативной, ассоциативной, дистрибутивной?

7. Какой элемент называется нейтральным, симметричным относительно бинарной операции на множестве?

8. Изложите суть аддитивной и мультипликативной формы записи множества с заданной на нем бинарной операцией.

9. Что называется группой? Какая группа называется абелевой?

10. Что называется кольцом, полем?

Тема 5. Поле комплексных чисел

1. Что называется полем комплексных чисел?

2. Какая запись комплексного числа называется алгебраической формой?

3. Как определяются операции сложения, вычитания, умножения и деления комплексных чисел в алгебраической форме?

4. Что понимают под геометрическим представлением комплексного числа?

5. Что называется модулем и аргументом комплексного числа? Как они вычисляются?

6. Какая запись комплексного числа называется тригонометрической формой?

7. Как определяются операции умножения и деления комплексных чисел в тригонометрической форме?

8. Напишите формулу возведения в степень комплексного числа и формулу извлечения корня из комплексного числа.